Home > Error Error > Error Error_platform_failure

Error Error_platform_failure


AttachmentSize mainphp.txt22.53 KB valiant Joined:2003-01-04 Posts:32509 Posted: Thu, 2006-11-02 13:06 i'm interested in the content of the main.php files of the multisites, not in the one of the codebase. Might be easier just to start over? Do you think it's maybe that I have my /g2data/ folder "under" public_html (i.e. please delete /hsphere/local/home/fritzenw/silverstorm.ch/pictures-gallery-public/g2data/smarty/template_c/ 3.

I contacted my hosting provider (hostrocket.com) and they had recently implemented "php su exec" on the server in which my site is being hosted. documentation downloads search forums support development login Home » Forums » Gallery 2 Support » Migrating to Gallery 2 [SOLVED] Error (ERROR_PLATFORM_FAILURE, ERROR_UNKNOWN) evers310 Joined:2004-12-04 Posts:3 Posted: Wed, 2005-06-08 20:21 This accessible?)? All else is © Copyright 2000-2014 Bharat Mediratta. http://galleryproject.org/node/23889

Error Error_platform_failure

cheers valiant Joined:2003-01-04 Posts:32509 Posted: Sat, 2006-11-04 03:24 you always have to upgrade each multisite one by one. h0bbel - Gallery Team If you found my help useful, please consider donating to Gallery http://h0bbel.p0ggel.org

Chisa Joined:2007-01-10 Posts:14 Posted: Wed, 2007-01-10 13:28 Hrmm, I tried the same with a Is there anything else I could do? Try to change the folder permissions recursively. -------------- Enter the Gallery 2 Theme Contest today!

you posted 2 errors: 1. Silverstorm Joined:2006-01-20 Posts:121 Posted: Fri, 2006-11-03 23:55 valiant wrote: are you sure those multisites have been upgraded correctly?

actually, I can't remember upgrading them at all. I feel that cache fills very quickly. do you have a backup of a point in time where all this stuff worked? > I tried to upload a backup of the database and there are also no _g2

I contacted my hosting provider (hostrocket.com) and they had recently implemented "php su exec" on the server in which my site is being hosted. Error Error Storage Failure you don't need to run the installation wizard for the codebase... Turned on debug mode but still have no idea how to decipher it : http://www.chigarden.com/gallery2/gallery2/main.php valiant Joined:2003-01-04 Posts:32509 Posted: Wed, 2007-01-10 13:59 That's also platform related. got to use SmartFTP to CHMOD -R 777 to all G2data and below it.

Initially it was /home/tacoma/g2data. If their house (ix) isn't in order, it doesn't appear that making changes would be advisable. pulser Joined:2005-05-29 Posts:88 Posted: Wed, 2006-07-19 12:26 Quote: Any other ideas????

Yes. I spent hours fixing this today.

Error Error Storage Failure

Just to make sure it really is the same thing. --Andy Consider giving back to Gallery Gallery Paid Support http://www.andylindeman.com bobbit Joined:2008-07-21 Posts:5 Posted: Tue, 2008-07-22 00:35 Ugh. changed permissions back to 777 and 755 but still no luck... Error Error_platform_failure This thread already mentions all that I have tried so far. and what's the content of the main.php file in your multisite folders?

Caygill Joined:2005-09-12 Posts:10 Posted: Tue, 2006-10-17 10:58 Exact the same problem, had run chown earlier to myuser:myusergrp and when I changed /g2data back to www:www (as php runs on our box) There was a power outage and the server restarted. All are latest 2.1.2 galleries. at line 0 (ItemEditWatermark::bulkOperation) * in modules/core/classes/GalleryTemplateAdapter.class at line 915 * in /home/jaaree/gallery2/g2data/smarty/templates_c/%%487946764/%%A2^A21^A2113948%%theme.tpl.php at line 166 (GalleryTemplateAdapter::trailer) * in lib/smarty/Smarty.class.php at line 1258 * in modules/core/classes/GallerySmarty.class at line 61 (Smarty::fetch) *

  1. bretts Joined:2006-08-09 Posts:5 Posted: Wed, 2006-08-09 06:49 Folks, I ran into the same issue this evening after having not touched my site since June 2006.
  2. G2 valiant Joined:2003-01-04 Posts:32509 Posted: Wed, 2005-10-05 15:13 ask your webhost to chmod -R 777 /path/to/your/g2data or chown -R newuser /path/to/your/g2data whereas newuser should be replaced with the username as
  3. you need to chmod all dirs you own to 777 and all files you own to 666, or have the owner changed back.
  4. After that, something was going on, but not a good thing...
  5. If all fails, please ask in the forum for help such that we can verify that it is indeed a filesystem permissions problem.
  6. Silverstorm Joined:2006-01-20 Posts:121 Posted: Thu, 2006-11-02 15:33 Ouu, sorry my fault The content of the main.php of both multisites are identical and show the following: --------------------------------------------------------------------------------------
  7. What can I do to fix the poblem.
  8. Dave ____________________________________________ Blog & G2 || floridave - Gallery Team All logos, trademarks and content in this site are property of their respective owners.

I went back into my configuration, and set the path back... at line 0 (itemaddcontroller::handlerequestwithprogressbar) in modules/core/classes/GalleryTemplateAdapter.class at line 1089 in g2data/smarty/templates_c/%%1853414869/carbon/%%2E^2E1^2E11E2E2%%theme.tpl.php at line 147 (gallerytemplateadapter::trailer) in lib/smarty/Smarty.class.php at line 1255 in modules/core/classes/GallerySmarty.class at line 61 (smarty::fetch) in modules/core/classes/GalleryTemplate.class at line 241 After they switched it off for my domain - my gallery started working just great! valiant Joined:2003-01-04 Posts:32509 Posted: Thu, 2006-11-02 15:55 well then everything looks fine.

THANKS! Perhaps you didn't notice, minutedesigns, that 1) the thread died more than a year ago, and 2) whoever makes Gallery has no intention of providing anything resembling "support," so we are I'll email Garbor about it tomorrow and see if he has any ideas.

contacted my hosting company and we found out that the problem was a safe mode that they switched on for PHP.

How can I solve this problem? Then I used the "Local Server Upload Paths" to get the old albums and photos and so far so good. Might be time for a phone call so I can yell at someone over there. Chisa Joined:2007-01-10 Posts:14 Posted: Tue, 2007-01-16 14:21 It's seems I've somehow set my storage directory to be the same as the gallery directory...

Back to top #2 TCH-Bala TCH-Bala Technical Support Manager Staff 1,433 posts Posted 25 May 2011 - 10:07 PM With suPHP you cannot have 777 permissions, but the same can be I have 2 gallery2 installations on 2 different servers and they both run fine.Thanks, Bruce. would it just be the modules folder? I know its not wise to just change everything...

If not, how can I access it directly? Missing Code The code for some plugins that were previously active can no longer be found. Thanks in advance Silverstorm XUser login Login/Register jazza Joined:2006-07-18 Posts:6 Posted: Tue, 2006-07-18 04:59 Did you manage to resolve this issue in the end? If you migrated from G1, just remigrate after you reinstall the newest g2-version.

Time for an upgrade I think! I'll post up what ix comes back with. valiant Joined:2003-01-04 Posts:32509 Posted: Wed, 2007-01-10 14:39 nope, that's about the storage folder. Matt Thorn http://matt-thorn.com Matt Thorn Joined:2008-09-18 Posts:3 Posted: Mon, 2008-09-22 12:46 Hello?

Thank you Silverstorm Silverstorm Joined:2006-01-20 Posts:121 Posted: Sun, 2006-10-29 17:42 Dear support team I am writing to you now again because I can't get out of this trouble. Up to alpha-4, upgrading requires a total reinstall (loosing all your pics/albums/settings).