Home > Error Failed > Error Failed Dependencies Libmysqlclient.so

Error Failed Dependencies Libmysqlclient.so

Contents

RHN support will be disabled. What does Peter Dinklage eat on camera in Game of Thrones? When should I refuel my vehicle? I get this error: Syntax error on line 6 of /etc/httpd/conf.d/auth_mysql.conf: Cannot load /etc/httpd/modules/mod_auth_mysql.so into server: /usr/lib64/mysql/libmysqlclient.so.10: symbol __fprintf_chk, version GLIBC_2.3.4 not defined in file libc.so.6 with link time reference. http://invictanetworks.net/error-failed/error-failed-dependencies-libmysqlclient-so-15.html

I need to know how to fix these dependencies ... updates is included, but repoquery --location mysql-libs returns nothing –hpn Jul 7 '13 at 8:42 | show 2 more comments up vote 0 down vote As from your question it is Had "MySQL-shared-compat-5.5.16″ (client libraries, including support for older clients) been installed as opposed to just "MySQL-shared-5.5.16″ (5.5 client libs), then the perl-DBD-MySQL would have installed fine. Browse other questions tagged centos yum or ask your own question. http://stackoverflow.com/questions/8889603/linux-dependency-libmysqlclient-so-15-not-found

Error Failed Dependencies Libmysqlclient.so

share|improve this answer answered Dec 16 '11 at 17:16 s1los 483 add a comment| up vote 0 down vote Install the remi repository: http://blog.famillecollet.com/pages/Config-en Enterprise Linux 6 (with EPEL) i386 or Not the answer you're looking for? centos yum share|improve this question edited Oct 7 '15 at 12:55 G-Man 6,31051728 asked Jul 7 '13 at 7:24 hpn 47541020 1 This issue is a bit old but as

  • Installed Packages MySQL-client.x86_64 5.5.16-1.rhel5 installed MySQL-devel.x86_64 5.5.16-1.rhel5 installed MySQL-embedded.x86_64 5.5.16-1.rhel5 installed MySQL-server.x86_64 5.5.16-1.rhel5 installed MySQL-shared.x86_64 5.5.16-1.rhel5 installed MySQL-test.x86_64 5.5.16-1.rhel5 installed I've tried to searching the web for a solution but couldn't
  • Please, send the results of uname -a from your system. [25 Jul 2007 6:54] paul sanz uname -a Linux logos 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 14:56:37 EDT 2007 x86_64 x86_64
  • Try installing the Mysql-shared-compat if there is one I had to install the old centos 5 mysqlclient15 rpm from remi to make this work for me though asawyer13 Name: Alan Sawyer
  • Hence, the reported issue is fixed.
  • Please, can someone help me to resolve this issue?
  • Transaction Check Error: file /etc/my.cnf from install of mysql-libs-5.5.27-11.el5.art.x86_64 conflicts with file from package Percona-Server-server-55-5.5.27-rel28.1.296.rhel5.x86_64 file /etc/my.cnf from install of mysql-libs-5.5.27-11.el5.art.i386 conflicts with file from package Percona-Server-server-55-5.5.27-rel28.1.296.rhel5.x86_64 Error Summary ------------- [[email protected]
  • It appears that the PHP4 mysql.so requires the libmysqlclient.so.10 delivered by MySQl 3...
  • Top Lenard Posts: 2283 Joined: 2005/11/29 02:35:25 Location: Indiana Can't install perl-DBD-MySQL Quote Postby Lenard » 2008/02/21 01:03:26 Strange, when I do yum whatprovides libmysqlclient.so.15 I see;mysql.i386 5.0.22-2.2.el5_1.1 updatesMatched from:/usr/lib/mysql/libmysqlclient.so.15.0.0/usr/lib/mysql/libmysqlclient.so.15libmysqlclient.so.15libmysqlclient.so.15(libmysqlclient_15)mysql.x86_64 5.0.22-2.2.el5_1.1
  • I'd recommend you to verify PHP configuration (check, is it needed to change any directories, library versions etc according to the new MySQL version installed), as it is suggested.
  • Failed dependencies problem [libmysqlclient.so.15] Discussion in 'Database Discussions' started by chiefme, Apr 18, 2012.

When I try to install a newer version (server-4.1) I get some dependence errors: [[email protected] mysql]# rpm -hUv --test MySQL-server-4.1.12-1.glibc23.x86_64.rpm warning: MySQL-server-4.1.12-1.glibc23.x86_64.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5 error: Failed Learn More. Legal Policies Your Privacy Rights Terms of Use Contact Us Portions of this website are copyright © 2001, 2002 The PHP Group Page generated in 0.032 sec. Transaction Check Error: file /etc/my.cnf from install of mysql-libs-5.5.22-1.el5.remi.x86_64 conflicts with file from package Percona-Server-server-55-5.5.21-rel25.1.234.rhel5.x86_64 and so on.

But this does NOT look like a bug in a mysql code... [27 Jul 2007 9:48] paul sanz Sorry my fault didnt realise, I managed to fix up2date and used that more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". I'd recommend to use tar.gz distribution (http://dev.mysql.com/get/Downloads/MySQL-4.1/mysql-standard-4.1.14-unknown-linux-gnu-x86_6...), but there are RPM's also: http://dev.mysql.com/get/Downloads/MySQL-4.1/MySQL-server-4.1.14-0.glibc23.x86_64.rpm/from...

Why do Trampolines work? If it will not help, I think, you have to reinstall php-mysql-4.3.10-2.4 (or a newer package version) and it should pick a new configuration. Once I had a chest full of treasures How to solve the old 'gun on a spaceship' problem? My Question: Is there a way to have v15 and v16 of libmysqlclient.so installed on the same system and if so how would I go about it?

mysql centos yum sphinxsearch share|improve this question asked Dec 16 '11 at 15:09 dSquared 1154 add a comment| 2 Answers 2 active oldest votes up vote 1 down vote install the dig this when I am running MySQL-4... (not at the server right now). Error Failed Dependencies Libmysqlclient.so regds sasikala. Robin Bowes (robinbowes) wrote on 2012-10-10: #7 "it is fixed, however, the issue remains" Do you mean "It is not fixed" ?

Please wait.---> Package libdbi-drivers.i386 0:0.8.1a-1.2.2 set to be updated--> Running transaction check--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package:libdbi-dbd-mysql--> Processing Dependency: libdbi >= 0.8 for package: libdbi-drivers--> Processing Dependency: libmysqlclient.so.15 for package: perl-DBD-MySQL--> useful reference Translation of "help each other" Why is there a white line on Russian fighter jet's instrument panel? found it here http://mirrors.dedipower.com/www.mysql.com/Downloads/MySQL-5.5/MySQL-shared-compat-5.5.23-1.sles11.x86_64.rpm share|improve this answer edited Jun 14 '12 at 10:24 Widor 8,67042351 answered Jun 14 '12 at 10:20 Boniface 192 The link doesn't work anymore. –kenorb I have libmysqlclient.so.16 as part of MySQL / MySQL-devel.

For a week all run ok, until I restarted the web server (httpd). Granted, it's a little weak, but with this info you can run the following command to determine the package that contains this .so library file: $ yum provides "*libmysqlclient.so.16*" which will Hope this helps any out there who run into this issue using yum to install the perl-DBD-MySQL module on 5.5 (and if you didn't install shared-compat). my review here linux dependencies centos rpm libmysql share|improve this question edited Mar 9 '14 at 12:57 kenorb 21.5k8151123 asked Jan 17 '12 at 4:22 user345824 1 yum install mysql? –Kevin Jan 17

i'm running the command: rpm -ivh sphinx-2.0.1-1.el5.x86_64.rpm and get the error: error: Failed dependencies: libmysqlclient.so.15()(64bit) is needed by sphinx-2.0.1-1.el5.x86_64 libmysqlclient.so.15(libmysqlclient_15)(64bit) is needed by sphinx-2.0.1-1.el5.x86_64 although i have mysql client already installed: No, create an account now. Key facts are that this server is now running 5.5, but was running 5.0.77 at a prior time.

I'm on CentOS 6.4 and it's in the updates repo which is part of the base installation. –slm♦ Jul 7 '13 at 8:18 It's 6.3 ...... –hpn Jul 7

Thank you! From this you now know which package provides the file, mysql-libs. So I checked all installed mysql rpms: shell$ rpm -qa -last | grep -i mysql MySQL-test-5.5.16-1.linux2.6 Tue 25 Jan 2011 12:54:28 PM EST MySQL-server-5.5.16-1.linux2.6 Tue 25 Jan 2011 12:54:20 PM EST Installing MySQL-shared-compat solved the problem.

So, I'd like to add an answer, which is there: stackoverflow.com/questions/37756308/… –cdr Jun 15 at 13:13 add a comment| 2 Answers 2 active oldest votes up vote 3 down vote accepted Post Reply Print view Search Advanced search 7 posts • Page 1 of 1 pcwitchdoctor Posts: 5 Joined: 2008/02/20 02:29:32 Can't install perl-DBD-MySQL Quote Postby pcwitchdoctor » 2008/02/20 21:56:40 When I See full activity log To post a comment you must log in. get redirected here Can anyone tell me best way to get so.15 on the system without breaking anything?

And just be certain, we installed the shared-compat (used rpm -Uvh package_name), then re-ran the "yum install perl-DBD-MySQL", and it installed perfectly.