Home > Error Failed > Error Failed To Build Gem Native Extension. /usr/bin/ruby Extconf.rb

Error Failed To Build Gem Native Extension. /usr/bin/ruby Extconf.rb

Contents

kenorb referenced this issue Nov 20, 2015 Closed Sqlite 3 error #237 jorgeorpinel commented Nov 20, 2015 I had a similar problem with Overcommit. @kenorb 's instructions worked for me: installing Could clouds on aircraft wings produce lightning? It says No available formula with the name "ruby-dev" chlab commented Jan 12, 2016 Nope, that's the debian package name, not necessarily the homebrew name. V-brake arm not returning to "open" position Wrong password - number of retries - what's a good number to allow? my review here

They did not provide the answer I require. Maybe try this: fedora-tunisia.org/?q=node/44 Let me know if it works. –Nowaker Nov 29 '10 at 14:31 I just had this problem here: stackoverflow.com/questions/6297751/… Good solution! –Kevin Brown Jun 9 ruby json gem share|improve this question asked Dec 13 '13 at 4:44 Navneet 1,46651739 check presense of /usr/lib/ruby/ruby.h file, if it is present, show us error message from gem_make.out. Hope it works for you as well! http://stackoverflow.com/questions/4304438/gem-install-failed-to-build-gem-native-extension-cant-find-header-files

Error Failed To Build Gem Native Extension. /usr/bin/ruby Extconf.rb

share|improve this answer answered Aug 29 '14 at 1:09 John Ryan 7017 This does not provide an answer to the question. Should I serve jury duty when I have no respect for the judge? sunilkr commented Jul 9, 2014 At this point I would suggest re-installing ruby. I have ruby 1.8.7.

For example: $ sudo apt-get install ruby2.2-dev share|improve this answer edited May 19 '15 at 17:11 answered Nov 26 '14 at 20:30 Dror S. 755611 1 and sudo apt-get install Trabucco Campos 28124 I recently had the same issue but with a newer version. Faison commented Jul 23, 2014 Oh, hi, I thought I responded. I have yum installed gcc, make, install, ruby-devel - in fact in a fit of trying everything I yum installed everything ruby20*, rubygem[s]20*, etc.

However this was already installed in my environment: $ xcode-select -p /Library/Developer/CommandLineTools Other suggestions said to install gcc... sudo gem install --http-proxy : json I get the following error: Building native extensions. Please enable JavaScript to view the comments powered by Disqus. asked 5 years ago viewed 122034 times active 4 days ago Linked 111 Error while installing json gem 'mkmf.rb can't find header files for ruby' 16 rails new or rails

You may also have to install other dependencies (Javascript and Python). Strategies for creating 3D text Is masking before unsigned left shift in C/C++ too paranoid? How to cope with too slow Wi-Fi at hotel? sudo apt-get install ruby-dev sudo apt-get install ruby2.0-dev sudo apt-get install ruby2.2-dev The first link you’ve posted is exactly your case: there is no ruby development environment installed.

epoxy for keying box headers? This could take a while... Error Failed To Build Gem Native Extension. /usr/bin/ruby Extconf.rb Will something accelerate forever if a constant force is applied to it on a frictionless surface? You signed in with another tab or window.

Why do Trampolines work? http://invictanetworks.net/error-failed/error-failed-to-build-gem-native-extension-ubuntu.html You must run xcode-select --install for gem install compass to work. What should I do? Section of a book that explains things How to create a plot with inclined axes?

  1. yes checking for ffi_raw_call()...
  2. sudo apt-get install gcc ruby-devel rubygems-integration ruby-compass share|improve this answer answered Sep 10 '15 at 9:32 onebraveman 566 add a comment| up vote 1 down vote sudo gem update --system sudo
  3. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed
  4. I needed additional packages.

Results logged to /home/dyego/.bundler/tmp/9200/extensions/x86_64-linux/2.1.0/sqlite3-1.3.9/gem_make.out An error occurred while installing sqlite3 (1.3.9), and Bundler cannot continue. A positive integer gets reduced by 9 times when one of its digits is deleted.... In that case build-essentials was an important item checked for along the way (Ubuntu system, not CentOS). http://invictanetworks.net/error-failed/error-failed-to-build-gem-native-extension-osx.html Results logged to /var/lib/gems/1.9.1/gems/eventmachine-1.0.3/ext/gem_make.out [email protected]:~$ cat /var/lib/gems/1.9.1/gems/eventmachine-1.0.3/ext/gem_make.out /usr/bin/ruby1.9.1 extconf.rb Here's what happened when I tried to install from source [email protected]:~/mailcatcher$ gem build mailcatcher.gemspec Successfully built RubyGem Name: mailcatcher Version: 0.6.0 File:

Not the answer you're looking for? mysql ruby rubygems share|improve this question edited Sep 27 at 17:45 Brian 3,74552341 asked Nov 29 '10 at 13:58 Tim 5,0772890147 Just a quick guess: do you have the ERROR: Error installing mailcatcher: ERROR: Failed to build gem native extension. /usr/bin/ruby1.9.1 extconf.rb Gem files will remain installed in /var/lib/gems/1.9.1/gems/eventmachine-1.0.3 for inspection.

Results logged to /Library/Ruby/Gems/2.0.0/extensions/universal-darwin-13/2.0.0/ffi-1.9.3/gem_make.out What's going on here?

Place all sed commands into one shell script file Are backpack nets an effective deterrent when going to rougher parts of the world? Subscribed! I updated my answer. –Dror S. This could take a while...

But now I have to update Ruby to Version >= 2.0 Fetching: mime-types-data-3.2016.0221.gem (100%) ERROR: Error installing mailcatcher: mime-types-data requires Ruby version >= 2.0. Set Up MAC Environment -Install the Xcode Command Line Tools this is the key to install Compass. redtrumpet commented Jun 13, 2015 Thanks, this solved my problem! http://invictanetworks.net/error-failed/error-failed-to-build-gem-native-extension.html tshriver commented Jul 7, 2015 Thanks!

But google told me to try gem install json -v 1.8.1 and that got further... Browse other questions tagged linux ubuntu ruby or ask your own question. ERROR: Error installing compass: ERROR: Failed to build gem native extension. /usr/bin/ruby extconf.rb mkmf.rb can't find header files for ruby at /usr/lib/ruby/ruby.h Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/ffi-1.9.6 for inspection. run bundle exec spring binstub --all /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:296:in `resolve': Could not find gem 'sqlite3 (>= 0) ruby' in the gems available on this machine. (Bundler::GemNotFound) from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:168:in `start' from /usr/lib/ruby/vendor_ruby/bundler/resolver.rb:129:in `block in

Success! How do I input n repetitions of a digit in bash, interactively Polyline split at node in QGIS Has she came or Did She came Tenant claims they paid rent in Once I had a chest full of treasures Section of a book that explains things What would it take to make thorium a prominent energy source? 15 Balls Sorting more hot Translation of "help each other" epoxy for keying box headers?

The question is what is needed besides. Try upgrading. –Pithikos Dec 31 '15 at 12:06 I got the same error as well, and I'm using a fully updated version of Linux Mint. Proxy has nothing to do with the problem: everything is downloaded fine, just compilation fails.